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FrostWire is a free, open-source peer-to-peer (P2P) BitTorrent client.

FrostWire is distributed by FrostWire, LLC.

FrostWire is not affiliated with LimeWire, LLC.

BitTorrent™, the BitTorrent™ logo, and Torrent™ are trademarks of 
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or distributing unauthorized files. It is illegal to distribute copyrighted files with-

out permission.

FrostWire, LLC condemns copyright infringement.
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of the DMCA will be denied access to FrostWire in the future, in accordance with 

FrostWire's DMCA Policy.

Please contact FrostWire, LLC with any questions, comments or concerns at 
contact@frostwire.com.
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About This Guide
Thank you for choosing FrostWire!

If you have not yet downloaded FrostWire, you can do so at www.frostwire.com. 

This is a full user guide for FrostWire 6, a free, open source BitTorrent client, media player and 
cloud downloader. This guide covers all aspects of using the FrostWire desktop application and is 
ideal for those who have never used FrostWire or a BitTorrent client before. I hope it can answer 
any questions you may have about using FrostWire. 

FrostWire is available for both mobile and desktop. This guide is strictly written for users of the 
FrostWire 6 desktop application. The content of this guide does not apply to mobile users.

This guide was written for credit in TCN700 and 709, courses in the Technical Communications 
program at Seneca College in Toronto, Ontario, Canada.

https://www.frostwire.com/
https://www.senecacollege.ca/programs/fulltime/TEC.html
https://www.senecacollege.ca/programs/fulltime/TEC.html


ii



iii

Table of Contents
About This Guide................................................................................. i

Table of Contents .............................................................................. iii

Chapter 1: Getting Started with FrostWire.......................................... 7

What is FrostWire? .........................................................................................7

What is BitTorrent? ........................................................................................8

What is a BitTorrent client?............................................................................8

What is Seeding? ............................................................................................8

Setting up FrostWire Using the Setup Wizard ................................................9

Configuring the BitTorrent Sharing Settings ............................................................  9

Configuring the Miscellaneous Settings.................................................................  10

Joining the FrostWire Community..........................................................................  11

Stating your Intent..................................................................................................  11

Chapter 2: Using the Search Tab ....................................................... 13

About the Search Tab ...................................................................................13

Using the Search Bar to Search for Files.......................................................13

Viewing Search Results.................................................................................14

Filtering Results by File Type ..................................................................................  14

Downloading a File .......................................................................................15

Using the Search Tools Sidebar ....................................................................15

Searching for and Selecting Sources ......................................................................  16



iv
Filtering Results by Size ..........................................................................................  16

Filtering Results by Seeds .......................................................................................  16

Chapter 3: Using the Transfers Tab ................................................... 17

About the Transfers Tab ...............................................................................17

Managing Transfers ......................................................................................17

Filtering Transfers by Status ...................................................................................  18

Pausing, Resuming and Cancelling Downloads ......................................................  18

Viewing Download Locations .................................................................................  19

Using the Transfer Detail Panel ....................................................................19

Chapter 4: Using the Library Tab....................................................... 21

About the Library Tab...................................................................................21

Managing Your Library .................................................................................21

Searching and Filtering Your Library.............................................................22

Viewing Your Files Location Folder...............................................................22

Creating Playlists ..........................................................................................23

Creating a Blank Playlist..........................................................................................  23

Adding Files to a Playlist .........................................................................................  23

Removing Files From a Playlist ...............................................................................  24

Playing Files in the Media Player ..................................................................24

Sending Files from the Library Tab ...............................................................25

Chapter 5: Using the Media Player.................................................... 27

Playing Media ...............................................................................................27

Changing the Playback Mode .......................................................................28

Adjusting the Volume ...................................................................................28

Playing, Pausing and Changing Songs...........................................................28

Chapter 6: Using the Toolbar ............................................................ 29

Using the File Menu......................................................................................29

Sending a File or Folder from the File Menu..........................................................  29

Opening Torrents, Magnet Links and Video URLs..................................................  30

Creating a New Torrent ..........................................................................................  30

Shutting Down FrostWire .......................................................................................  31



v

Using the View Menu ...................................................................................31

Changing to Search/Transfers Split Screen View ...................................................  31

Changing the Icon Display ......................................................................................  32

Changing Font Size..................................................................................................  32

Changing Language.................................................................................................  32

Using the Tools Menu...................................................................................33

Rebuilding iTunes “FrostWire” Playlist...................................................................  33

Opening the Options Dialog Box ............................................................................  33

Viewing Update Status ...........................................................................................  33

Using the Help Menu....................................................................................34

Viewing External FrostWire Information................................................................  34

Viewing the Tip of The Day.....................................................................................  34

Viewing Information About FrostWire ...................................................................  35

Sending Feedback...................................................................................................  35

Chapter 7: Using the Options Dialog Box .......................................... 37

Accessing the Options Dialog Box.................................................................37

Changing BitTorrent Options........................................................................38

Changing the Default Save Folder ..........................................................................  38

Changing Seeding Settings .....................................................................................  38

Changing the BitTorrent Global Transfer Speeds ..................................................  39

Changing the BitTorrent Connection Settings .......................................................  39

Adding and Removing Library Folders ..........................................................41

Changing FrostWire Media Player Options ..................................................42

Changing Search Options..............................................................................42

Selecting Search Engines ........................................................................................  42

Setting the Maximum Number of Simultaneous Searches:...................................  43

Enabling and Disabling Smart Search .....................................................................  43

Showing or Hiding the Details Page .......................................................................  43

Enabling or Disabling the Status Bar Indicators............................................44

Enabling or Disabling the Connection Quality Indicator ........................................  44

Enabling or Disabling the Firewall Indicator...........................................................  44

Enabling or Disabling the Bandwidth Indicator......................................................  44



vi
Enabling or Disabling iTunes Importing........................................................45

Changing View Options.................................................................................45

Redisplaying FrostWire Popups..............................................................................  45

Enabling or Disabling FrostClick Promotions..........................................................  45

Enabling or Disabling FrostWire Recommendations .............................................  46

Enabling or Disabling Text Autocompletion...........................................................  46

Changing Filter Results .................................................................................46

Changing Advanced Options.........................................................................47

Enabling or Disabling Automatic Installer Downloads ...........................................  47

Enabling or Disabling Experimental Features ........................................................  48

Configuring Firewalls and Routers .........................................................................  48

Configuring Proxy Options......................................................................................  49

Changing Network Interface Options.....................................................................  49

Changing File Associations......................................................................................  49

Changing System Startup Options..........................................................................  50

Changing Shutdown Behaviour ....................................................................50

Changing Bug Report Options ......................................................................51

Restoring Default Settings ............................................................................51

Index ................................................................................................ 53

Glossary ........................................................................................... 57



Chapter 1: Getting Started with 
FrostWire
What is FrostWire?

FrostWire is a free, open source BitTorrent client, media player and cloud downloader. With 
FrostWire, you can easily search for and download files from BitTorrent and cloud sources. Frost-
Wire allows you to build your own media library and browse and play your media all in one place.

FrostWire 6 is available for:

• Windows
• Mac OSX
• Ubuntu
• .RPM
• TARBALL

Image 1.1: The FrostWire 6 user interface
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What is BitTorrent?

BitTorrent is a method of peer-to-peer (P2P) file sharing which allows you to share large files 
over the Internet. When you download a file from the Internet, it typically comes from a single. 
centralized server. Using BitTorrent, you can download files directly from other BitTorrent users. 
The file you download is called a torrent.

Image 1.2: Peer-to-peer (P2P) networking

What is a BitTorrent client?

BitTorrent clients are software that allow you to access the BitTorrent P2P network. FrostWire is 
a BitTorrent client.

What is Seeding?

Sharing a file over the BitTorrent P2P network is called seeding. Seeding allows other BitTorrent 
users to download files from both you and others on the BitTorrent P2P network. The more people 
seed a file, the faster and easier it becomes to download. 
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Chapter 1
Setting up FrostWire Using the Setup Wizard

Before you can begin using FrostWire, you must use the Setup Wizard to configure FrostWire. 
The Setup Wizard guides you through a series of steps that will help to ensure optimal perfor-
mance. 

Note: All of the settings in the Setup Wizard can be changed later in the Options dialog box.

Configuring the BitTorrent Sharing Settings

To configure FrostWire’s BitTorrent Sharing Settings using the Setup Wizard, you must indicate 
where you would like FrostWire to save your torrent data and choose whether to automatically 
seed your finished downloads. 

Image 1.3: The FrostWire Setup Wizard

Configuring the Torrent Data Save Folder Settings

By default, FrostWire creates its own folder for saving torrent data. You can choose to either save 
your torrent data in this default folder, or select a different folder. 

To use the default folder, click Use Default in the Torrent Data Save Folder section.

To use a different folder, click Browse in the Torrent Data Save Folder section and select a folder. 
Adam Pugsley | Page 9
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Configuring the Seeding Settings

In the Seeding Settings section, you have the option to allow FrostWire to automatically seed fin-
ished downloads. 

If you would like FrostWire to automatically seed finished downloads, click Seed finished down-
loads in the Seeding Settings section. FrostWire recommends you select this option.

If you do not want FrostWire to automatically seed finished downloads, click Don’t seed finished 
downloads in the Seeding Settings section. 

Configuring the Miscellaneous Settings

To configure FrostWire’s Miscellaneous Settings, you must indicate whether you would like 
FrostWire to start when you log into your computer. 

Image 1.4: The Miscellaneous Settings page of the Setup Wizard

If you would like FrostWire to start when you log into your computer, click Start Automatically 
in the System Startup section. If you do not want FrostWire to start automatically, click Next. 
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Chapter 1
Joining the FrostWire Community

On the Join Us page of the FrostWire Setup Wizard, links to FrostWire’s social media channels 
are provided. You are encouraged to visit FrostWire’s social media channels by clicking on the 
links and joining the community. 

Stating your Intent

Before you can use FrostWire, you must declare that you will not use FrostWire for copyright 
infringement. If you do not agree to this, you cannot use FrostWire. 

Warning: Downloading FrostWire does not constitute permission or a license for obtaining or 
distributing unauthorized files.

Image 1.5: The State Your Intent page of the Setup Wizard

To declare that you will not use FrostWire for copyright infringement, click I will not use Frost-
Wire 6 for copyright infringement. If you are finished using the Setup Wizard, click Finish to 
close the Setup Wizard window. 

Note: You can set FrostWire to start automatically when you turn on your computer. For more 
information, see “Changing System Startup Options” on page 50.
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Chapter 2: Using the Search 
Tab
About the Search Tab

The Search Tab allows you to search for, view and download files on the peer-to-peer (P2P) Bit-
Torrent network. To access the Search Tab, click Search.

Image 2.1: The Search Tab location. 

Using the Search Bar to Search for Files

To search for files, enter a keyword or paste a torrent, magnet or video page URL into one of the 
two search bars and press enter. The first search bar is located near the Search Tab. The second 
search bar is located in the blank Search Tab page. 
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Viewing Search Results

After using the search bar to search for a file, the results of your search are displayed in the Search 
Tab. Search results are stored in a search results tab. FrostWire allows you to conduct multiple 
searches and keep multiple search results tabs open at the same time. 

Image 2.2: The components of the Search results tabs. 

Within a search results tab, the column headings display the following information for each file:

• Available actions
• Number of seeds
• File type
• File name
• File size
• Source
• Date created
• Filename extension

Filtering Results by File Type

The file type filter buttons in the Search Tab allow you to filter the results of your search by file 
type. Using the file type filter buttons, you can view:

• Audio files (.mp3, .wav, .m4a, etc.) 
• Video files (.avi, .mpg, .wmv, etc.)
• Images (.jpg, .gif, .png, etc.) 
• Documents (.html, .txt, .pdf etc.)
• Program files (.exe, .zip, etc.)
• Torrents (.torrent)
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Chapter 2
Downloading a File

To download a file, either click Download in the Actions column or select a file and click Down-
load in the Search Tab. 

Image 2.3: The location of the Download icon.

Using the Search Tools Sidebar

The Search tools menu allows you to filter your search results by source, file size and number of 
seeds. To display the Search tools sidebar, click Search tools in a search results tab. 

Image 2.4: The location of the Search Tools sidebar. 
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Searching for and Selecting Sources

To filter the search results displayed in the open search results tab by source, you can either enter 
a keyword into the search bar in the Search tools sidebar or use the source check boxes.

Image 2.5: The Search Tools sidebar. 

By default, all of the sources are displayed. To remove a source from your search result, deselect 
the source name by clicking the check box. 

Filtering Results by Size

To filter your search results by file size, use the Size slider in the Search tools sidebar to set the 
minimum and maximum file sizes you want to be displayed in the search results tab. 

Filtering Results by Seeds

To filter your search results by number of seeds, use the Seeds slider in the Search tools sidebar to 
set the minimum and maximum number of seeds per file that you want to be displayed in the 
search results tab. 
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Chapter 3: Using the Transfers 
Tab
About the Transfers Tab

The Transfers Tab displays information about your transfers. After starting to download a file, 
you can view the status of your download in the Transfers Tab, as well as view information about 
seeding and completed downloads. To access the Transfers Tab, click Transfers.

Image 3.1: The location of the Transfers Tab. 

Managing Transfers

Using the Transfers Tab, you can view the name, file size, status, download progress, and seeding 
information for your transfers. 
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Filtering Transfers by Status

Using the Transfers Tab, you can view your transfers by status. The transfer status filter buttons 
allow you to view your downloading, seeding, and finished transfers. See Table 3.1 for details on 
using the transfer status filter buttons. 

Image 3.2: The transfer status filter buttons

Image 3.3: The location of the icons. 

If you want to: Then:

View all of your transfers Click All

View your downloading transfers Click Downloading

View your seeding transfers Click Seeding 

View your finished transfers Click Finished

Table 3.1: Transfer status filter buttons

Pausing, Resuming and Cancelling Downloads

The Transfers Tab has several buttons that allow you to change the status of your download. To 
change the status of a download, click the download and then select an icon. See Table 3.2 for 
details on pausing, resuming and cancelling downloads.
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Chapter 3
Viewing Download Locations

To view the contents of a transfer in the Library Tab, select the transfer and click Show in the 
Transfers Tab.

To open the folder on your computer that contains the downloaded file, select the transfer and 
click Explore in the Transfers Tab. 

Using the Transfer Detail Panel

When you select a transfer from the Transfers Tab, the Transfer Detail panel is displayed. The 
Transfer Detail panel displays further information about the selected transfer. 

Information in the Transfer Detail panel is organized into the following categories:

• General information about the selected transfer
• Files included in the transfer
• Pieces
• Trackers 
• Peers 

To view the information in one of these categories, click the category buttons in the Transfer 
Detail panel. For information about these categories, see “Glossary” on page 57.

Image 3.4: Category buttons of the Transfer Detail panel. 

If you want to: Then select the download and:

Pause a download Click Pause 

Resume a download Click Resume

Cancel a download Click Cancel 

Retry a failed download Click Retry Transfer 

Table 3.2: Pausing, Resuming and Cancelling Downloads
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Chapter 4: Using the Library 
Tab
About the Library Tab

The Library Tab allows you to view your downloads, launch files in the media player, and create 
playlists. To access the Library Tab, click Library.

Image 4.1: The location of the Library Tab

Managing Your Library 

Files in your library are displayed in the center panel of the Library Tab. Using the Library Tab, 
you can:

• View your files
• Launch files using the Media Player
• Open the folder containing your files
• Share files with others
• Delete files
• Create playlists 
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Searching and Filtering Your Library

To search for files in your library, enter a keyword into the search box. The results of your search 
will be displayed in the center panel of the Library Tab. 

Image 4.2: The Search Tab search box and file type filters

To view the files in your library by file type, select one of the file type filters. Click on the file 
type you wish to view, and the results will be displayed in the center panel of the Library Tab. 

If you wish to view all of your files, regardless of file type, click the Default Save Folder filter to 
display your files in the center panel. 

Viewing Your Files Location Folder

To see where your downloaded file is saved on your computer, select the file from the center panel 
of the Library Tab and then click Explore in the Library Tab. The folder containing the file will 
then display.
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Chapter 4
Creating Playlists

FrostWire makes it easy to create playlists using the files in your library. FrostWire automatically 
creates an empty default playlist titled “Starred” that you can add songs to. You can also create 
and name your own custom playlists. Playlists can be accessed from the playlists panel in the 
Library Tab. 

Creating a Blank Playlist

To create a blank playlist:

1. Select New Playlist from the playlist panel.
2. Enter a name for the playlist into the text box. 
3. Press enter on your keyboard to create the playlist. 

Image 4.3: The Library Tab playlist panel

Adding Files to a Playlist

To add files to a playlist, either drag the file from the center panel of the Library Tab to the playlist 
panel and drop it over the name of the playlist you want to add it to, or:

1. Right-click the file you want to add to a playlist
2. Select Add to playlist 
3. Click the name of the playlist you want to add the file to. The file is now added to the playlist.
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Removing Files From a Playlist

To remove a file from a playlist, select the file from within the playlist and click Delete. The file 
will no longer be included in the playlist. 

Image 4.4: The Delete icon

Playing Files in the Media Player

To play a file using FrostWire’s Media Player, either select a file and click Launch in the Library 
Tab, or click the Play/Preview action button of the file you wish you play.

For more information on using the Media Player, see “Chapter 5: Using the Media Player” on 
page 27..

Image 4.5: The Launch icon and the Play/Preview button.
Adam Pugsley | Page 24



Chapter 4
Sending Files from the Library Tab

FrostWire allows you to share with others the files that you have downloaded. This can be done 
from either the Library Tab or the File Menu. For information on sending a file from the File 
Menu, see “Sending a File or Folder from the File Menu” on page 29.

To share a file from the Library Tab:

1. Select one or more files from the center panel. 
2. Click Send in the Library Tab. A dialog box displays asking you if you would like to send the 

selected file(s) to a friend. 
3. Click Yes to continue. The All done! Now share the link dialog box displays.
4. Select one of the four sharing options displayed in the dialog box.
5. Provide the information to the person you would like to receive the file. 

Note: Keep FrostWire open until the file has been downloaded by at least one other person.

Image 4.6: The All done! Now share the link dialog box
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Chapter 5: Using the Media 
Player
Playing Media 

FrostWire’s Media Player allows you to play files from your library. When active, the Media 
Player displays the file name, length, and current playback location of the file being played. 

Image 5.1: The Media Player

To play a file in the Media Player, launch a file from the Library Tab by selecting the file and 
clicking the Launch icon in the Library Tab. Alternatively, click the Play/Preview action button 
of the file you wish you play. For more information about using the Library Tab, see “Chapter 4: 
Using the Library Tab” on page 21.

Image 5.2: The Media Player functions
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Changing the Playback Mode

The playback mode of the Media Player can be changed to repeat or shuffle. For information 
about changing the playback mode of the Media Player, see Table 5.1 

Adjusting the Volume

To change the volume in the Media Player, use the Volume slider to select your desired volume. 
Moving the slider to the left will decrease the volume, and moving the slider to the right will 
increase the volume. 

Playing, Pausing and Changing Songs

The Play/Pause button of the Media Player allows you to start and stop playback of a file from 
your library. For information about playing, pausing, and changing songs in the Media Player, see 
Table 5.2.

If you want to: Then

Set the playback mode to repeat Click Repeat once

Set the playback mode to single repeat Click Repeat twice

Set the playback mode to shuffle Click Shuffle

Image 5.3: Media Player Playback Modes

If you want to: Then

Pause playback of a file Click Pause 

Resume playback of a file Click Play

Play the next file in your library or playlist Click Next 

Play the previous file in your library or playlist Click Previous 

Image 5.4: Playing, Pausing, and Changing Songs in the Media Player
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Chapter 6: Using the Toolbar
FrostWire’s toolbar is located at the top of the application window and allows you to access a 
variety of options relating to the functionality of the application.

Using the File Menu

The File menu provides additional functions for managing files in FrostWire. 

Sending a File or Folder from the File Menu

FrostWire allows you to send a file or folder from your computer to someone else on the BitTor-
rent P2P network. This can be done from either the Library Tab or the File Menu. For information 
on sending a file from the Library Tab, see “Sending Files from the Library Tab” on page 25.

To send a file or folder from the File Menu:

1. Click File in the toolbar
2. Select Send a file or folder... from the dropdown menu. A new window displays prompting 

you to select a file that you want to send. 
3. Within the window, navigate to and select the file or folder that you wish to send.
4. Click Select. A dialog box displays with sharing information.
5. Select one of the four sharing options displayed in the dialog box.
6. Provide the information to the person you would like to receive the file.
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Opening Torrents, Magnet Links and Video URLs

Rather than searching for files using the Search Tab, FrostWire also allows you to use a torrent 
link, magnet link, or web address to download files. For information about links and URLs, see 
“Glossary” on page 57.

To download a file using a torrent link, magnet link or video URL:

1. Click File in the toolbar
2. Select Open .Torrent, Magnet or Video URL from the dropdown menu. The Download 

.Torrent or Magnet Link box displays. 
3. Type or paste the magnet link, file path or web address of the torrent file you want to down-

load into the Open text box.
4. Click OK. FrostWire will start downloading the torrent. 

Creating a New Torrent

FrostWire allows you to create your own torrents to be shared on the BitTorrent peer-to-peer 
(P2P) network. For more information on BitTorrent and P2P networks, see “What is BitTorrent?” 
on page 8.

To create a new torrent:

1. Click File in the toolbar.
2. Select Create New Torrent from the dropdown menu. The Create New Torrent window dis-

plays. 
3. In the Torrent Contents section of the Contents and Tracking tab, click either Select File or 

Select Folder. A file navigation window displays. 
4. Within the file navigation window, navigate to and select the file or folder you want to create 

a new torrent with.
5. Click Open. The file path of the selected file or folder will now be displayed in the Torrent 

Contents text box.
6. Click Save torrent as.... The Save .torrent window displays. 

Note: If you are the content creator of the file and wish to choose a Copyright License for 
the work, you can do so in the Copyright License tab.

7. Using the Save .torrent window, select the location on your computer that you want to save 
your new torrent in.

8. Click Save. Your new torrent will now be displayed in the Transfers Tab. 
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Chapter 7
Shutting Down FrostWire

You can shut down FrostWire from the File menu in the toolbar. To shut down FrostWire, select 
either Close or Exit from the File dropdown menu in the toolbar. 

Using the View Menu

The View dropdown menu in toolbar has several options for changing FrostWire’s appearance. 

Changing to Search/Transfers Split Screen View

If you would prefer to have your transfers permanently visible within FrostWire, you can change 
to the Search/Transfers split screen view. 

With FrostWire set to the Search/Transfers split screen view, the Transfers Tab is replaced with a 
Transfers section that is permanently visible. 

Image 6.1: The Search/Transfers split screen view

To change to the Search/Transfers split screen view:

1. Click View in the toolbar.
2. Select Search/Transfers split screen from the dropdown menu. A message box displays 

informing you that you need to restart FrostWire for the change to take effect.
3. Click OK to close the message box.
4. Close FrostWire.
5. Reopen FrostWire. The Search/Transfers split screen view is now active. 
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Changing the Icon Display

If you would prefer to have FrostWire’s icons display at a smaller size, you can change this using 
the View dropdown menu in the toolbar. To use small icons, click View in the toolbar and select 
Use Small Icons from the dropdown menu. FrostWire’s icons will now display in a small size. To 
revert back to regular sized icons, deselect Use Small Icons in the View dropdown menu. 

You can also change whether or not FrostWire will display the icon text beneath the icons. By 
default, the icon text is displayed. If you would like to hide the icon text, click View in the toolbar 
and deselect Show Icon Text from the dropdown menu. The icon text will now be hidden. To dis-
play the icon text again, reselect Show Icon Text in the View dropdown menu. 

Changing Font Size

You can change the font size within FrostWire from the View dropdown menu in the toolbar. 

To increase the font size, click View in the toolbar and select Increase Font Size from the drop-
down menu. You can also increase the font size by pressing Control + Plus on your keyboard.

To decrease the font size, click View in the toolbar and select Decrease Font Size from the drop-
down menu. You can also decrease the font size by pressing Control + Minus on your keyboard.

Changing Language

FrostWire can be used in a variety of languages. 

To change the language displayed in FrostWire:

1. Click View in the toolbar.
2. Select Change Language from the dropdown menu. The Change language box is displayed.
3. From the dropdown menu in the Change language box, select your preferred language. 
4. Click OK to close the Change language box. A message box will display informing you of the 

need to restart FrostWire.
5. Press OK to close the message box. 
6. Close FrostWire.
7. Reopen FrostWire. FrostWire will now be displayed in your language of choice. 
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Chapter 7
Using the Tools Menu

Using FrostWire’s Tools menu, you can rebuild your iTunes “FrostWire” playlist, access the 
Options dialog box, and ensure FrostWire is up to date. 

Rebuilding iTunes “FrostWire” Playlist

FrostWire can build an iTunes playlist for you using files from your FrostWire library. Rebuilding 
the iTunes “FrostWire” playlist removes the playlist from iTunes and replaces it with a new play-
list containing all of the compatible files in FrostWire’s “Torrent Data” folder. 

To rebuild your iTunes “FrostWire” playlist:

1. Click Tools in the toolbar.
2. Select Rebuild iTunes “FrostWire” Playlist from the dropdown menu. A warning box dis-

plays
3. Click Yes if you wish to continue. Your iTunes “FrostWire” playlist is now rebuilt. 

Opening the Options Dialog Box

The Options dialog box can be accessed from the Tools menu. To open the Options dialog box, 
click Tools in the toolbar and select Options from the dropdown menu. For information on using 
the Options dialog box, see “Chapter 7: Using the Options Dialog Box” on page 37.

Viewing Update Status

You can check to see if FrostWire is up to date using the Tools menu. To check the update status 
of FrostWire, click Tools in the toolbar. The update status of FrostWire is displayed in the drop-
down menu. 

Image 6.2: Checking FrostWire’s update status
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Using the Help Menu

The Help menu contains links to external information, and allows you to open the Tip of the Day, 
About FrostWire, and Send Feedback dialog boxes. 

Viewing External FrostWire Information

From the Help dropdown menu in the toolbar, you can access several links to external information 
about FrostWire. The links to external information included in the Help dropdown menu are:

• How to use FrostWire (Video)
• FrostWire for Android
• What is “Seeding”?
• What is a VPN? 
• Support FrostWire
• Support with CryptoCurrencies
• FrostClick.com
• Discord chat
• Reddit
• Follow us on Twitter
• Follow us on Facebook
• Follow us on Instagram
• Did you pay for FrostWire? 

To access the external information contained in these links, click Help in the toolbar and select 
the information you wish to view from the dropdown menu. The information will be displayed in 
your web browser. 

Viewing the Tip of The Day

The Tip of the Day dialog box displays useful tips about FrostWire. The Tip of the Day dialog box 
can be accessed from the Help menu by clicking Help in the toolbar and selecting Tip of the Day 
from the dropdown menu. 
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Viewing Information About FrostWire

The About FrostWire dialog box displays information about your version of FrostWire as well as 
developer information. The About FrostWire dialog box can be accessed from the Help menu by 
clicking Help in the toolbar and selecting About FrostWire from the dropdown menu. 

Sending Feedback

You can send feedback about FrostWire using the Feedback dialog box. This feedback can be 
used to improve FrostWire. 

To send feedback using the Feedback dialog box:

1. Click Help in the toolbar
2. Select Send Feedback from the dropdown menu. The Feedback dialog box displays. 

Image 6.3: The Send Feedback dialog box

3. In the large text box, enter your feedback.
4. Optional: enter your e-mail address into the E-mail text box.
5. Optional: enter your name into the Your Name text box.
6. Click Send to submit your feedback and close the Send Feedback dialog box. 
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Chapter 7: Using the Options 
Dialog Box
The Options dialog box allows you to change various settings to customize FrostWire to your lik-
ing. 

Accessing the Options Dialog Box

To access the Options dialog box, either click Options in the Library Tab or click Tools in the 
toolbar and select Options from the dropdown menu. 

Image 7.1: The Options dialog box
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Changing BitTorrent Options

The BitTorrent section of the Options dialog box allows you to change your default save folder, 
seeding settings, BitTorrent global transfer speeds and BitTorrent connection settings. 

Changing the Default Save Folder

FrostWire can save your downloads to any folder that you want. By default, FrostWire creates a 
folder called “Torrent Data” and saves your downloads to this folder.

To change the default save folder:

1. Select BitTorrent from the Options dialog box side navigation menu.
2. In the Default Save Folder section, click Browse....Within the Select Folder window, select 

the folder that you want FrostWire to save your downloads to. 
3. Click Select to confirm your choice. The Select Folder window will close. 
4. Click Apply to save your change.

Changing Seeding Settings

You can instruct FrostWire to automatically seed your finished downloads or not. The Seeding 
Settings section can be seen in Image 7.1 on page 37

The first time you open FrostWire, you are asked to indicate your preference in the Setup Wizard. 
If you want to change your choice, you can do so using the Seedings Settings section of the 
Options dialog window. 

To change the Seeding Settings:

1. Select BitTorrent from the Options dialog box side navigation menu.
2. In the Seeding Settings section, indicate whether you would like FrostWire to automatically 

seed finished downloads by selecting the option button beside your choice. 
3. Click Apply to save your change.
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Changing the BitTorrent Global Transfer Speeds

In the BitTorrent Global Transfer Speeds section of the Options dialog box, you can set the maxi-
mum download and upload speeds for transfers in FrostWire. 

To change the BitTorrent global transfer speeds:

1. Select BitTorrent from the Options dialog box side navigation menu. 
2. Select Advanced from the BitTorrent dropdown in the Options dialog box side navigation 

menu.
3. In the BitTorrent Global Transfer Speeds section, use the Download Speed slider to set the 

maximum download speed in KB/s. 
4. Use the Upload Speed slider to set the maximum upload speed in KB/s. 
5. Click Apply to save your change.

Changing the BitTorrent Connection Settings

In the BitTorrent Connection Settings section of the Options dialog box, you can adjust your con-
nection settings to make the most use of your Internet connection within FrostWire. 

Enabling or Disabling Distributed Hash Table (DHT)

In the BitTorrent Connection Settings, you can enable or disable DHT. For information on DHT, 
see “Glossary” on page 57.

To enable or disable DHT:

1. Select BitTorrent from the Options dialog box side navigation menu. 
2. Select Advanced from the BitTorrent dropdown in the Options dialog box side navigation 

menu.
3. In the BitTorrent Connection Settings section, select or clear Distributed Hash Table (DHT) 

according to your preference. 
4. Click Apply to save your change.

Enabling or Disabling VPN Drop Protection

In the BitTorrent Connection Settings section of the Options dialog box, you can indicate whether 
you would like FrostWire to require a VPN in order to access files via the BitTorrent network. 

1. Select BitTorrent from the Options dialog box side navigation menu. 
2. Select Advanced from the BitTorrent dropdown.
3. In the BitTorrent Connection Settings section, select or clear VPN-Drop Protection. Require 

VPN for connection to BitTorrent according to your preference. 
4. Click Apply to save your change.
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Setting the Maximum Number of Active Downloads

In the BitTorrent Connection Settings section of the Options dialog box, you can indicate the 
maximum number of active downloads you would like FrostWire to allow. 

To set the maximum number of active downloads:

1. Select BitTorrent from the Options dialog box side navigation menu. 
2. Select Advanced from the BitTorrent dropdown in the Options dialog box side navigation 

menu.
3. In the BitTorrent Connection Settings section, type the maximum number of active downloads 

you would like FrostWire to allow into the Maximum active downloads text box.
4. Click Apply to save your change.

Setting the Maximum Number of Active Seeds

In the BitTorrent Connection Settings section of the Options dialog box, you can also indicate the 
maximum number of active seeds you would like FrostWire to allow. 

To set the maximum number of active seeds:

1. Select BitTorrent from the Options dialog box side navigation menu. 
2. Select Advanced from the BitTorrent dropdown in the Options dialog box side navigation 

menu.
3. In the BitTorrent Connection Settings section, type the maximum number of active downloads 

you would like FrostWire to allow into the Maximum active seeds text box.
4. Click Apply to save your change.

Setting the Global Maximum Number of Connections

In the BitTorrent Connection Settings section of the Options dialog box, you can change the 
global maximum number of connections you would like FrostWire to allow. This includes both 
downloads and seeds. 

To set the global maximum number of connections:

1. Select BitTorrent from the Options dialog box side navigation menu. 
2. Select Advanced from the BitTorrent dropdown in the Options dialog box side navigation 

menu.
3. In the BitTorrent Connection Settings section, type the global maximum number of connec-

tions you would like FrostWire to allow into the Global maximum number of connections 
text box.

4. Click Apply to save your change.
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Setting the Maximum Number of Peers

In the BitTorrent Connection Settings section of the Options dialog box, you can change the max-
imum number of peers you would like FrostWire to allow. 

To set the maximum number peers:

1. Select BitTorrent from the Options dialog box side navigation menu. 
2. Select Advanced from the BitTorrent dropdown in the Options dialog box side navigation 

menu.
3. In the BitTorrent Connection Settings section, type the maximum number of peers you would 

like FrostWire to allow into the Maximum number of peers text box.
4. Click Apply to save your change.

Adding and Removing Library Folders

In the Library Included Folders section of the Options dialog box, you can indicate which folders 
you would like to include in your FrostWire Library. All the compatible files in the indicated fold-
ers will be displayed in the Library Tab. For more information on the Library Tab, see “Chapter 4: 
Using the Library Tab” on page 21.

To add a library folder:

1. Select Library from the Options dialog box side navigation menu. 
2. In the Library included folders section, click Add. The Select Folder window displays.
3. Using the Select Folder window, select the folder you would like to be included in your Frost-

Wire Library. 
4. Click Select. 
5. Click Apply to save your change.

To remove a library folder:

1. Select Library from the Options dialog box side navigation menu. 
2. In the Library included folders section, select the folder you want to remove.
3. Click Remove.
4. Click Apply to save your change.

Note: You can also disable a folder rather than removing it. To enable or disable library folders, 
select or clear the checkbox beside the folder name in the Library included folders section.
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Changing FrostWire Media Player Options

If the formatting is supported, you can play your FrostWire media with your operating systems 
native media player. 

To play your media with the native media player:

1. Select Player from the Options dialog box side navigation menu.
2. In the FrostWire Media Player section, click Play with the native media player.
3. Click Apply to save your change.

To play search result video previews with your internal media player:

1. Select Player from the Options dialog box side navigation menu.
2. In the FrostWire Media Player section, click Play search result video previews with inter-

nal player.
3. Click Apply to save your change.

Changing Search Options

Using the Options dialog box, you can change the way FrostWire searches for files. You can 
instruct FrostWire on which search engines to use, set the maximum number of simultaneous 
searches, enable or disable Smart Search, and show the details web page. 

Selecting Search Engines

You can instruct FrostWire to only use particular search engines. For information about search 
engines, see “Glossary” on page 57.

To select which search engines you want FrostWire to use:

1. Select Searching from the Options dialog box side navigation menu.
2. In the Search Engines section, select which engines you want FrostWire to use by selecting or 

deselecting the checkboxes beside the search engine names.
3. Click Apply to save your change.
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Setting the Maximum Number of Simultaneous Searches:

To set the maximum number of simultaneous searches:

1. Select Searching from the Options dialog box side navigation menu.
2. In the Maximum searches section, enter the maximum number of simultaneous searches you 

want FrostWire to allow into the Maximum Searches text box.
3. Click Apply to save your change.

Enabling and Disabling Smart Search

The Smart Search database is used to make individual file searches faster. FrostWire remembers 
information about the content of torrent files to make this possible. You can choose whether to 
enable or disable Smart Search.

To enable or disable Smart Search:

1. Select Searching from the Options dialog box side navigation menu.
2. In the Smart Search section, select or clear Enable Smart Search according to your prefer-

ence.
3. Click Apply to save your change.

If you want to reset the Smart Search database, click Reset Smart Search Database in the Smart 
Search section.

Showing or Hiding the Details Page

You can choose whether or not FrostWire will display the details web page after a download 
begins. 

To show or hide the details web page:

1. Select Searching from the Options dialog box side navigation menu.
2. In the Details Page section, select or clear Show web details after a download starts accord-

ing to your preference.
3. Click Apply to save your change.
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Enabling or Disabling the Status Bar Indicators

The Status Bar is displayed along the bottom of the FrostWire application window and shows var-
ious information about FrostWire. Using the Options dialog box, you can enable or disable the 
Connection Quality, Firewall and Bandwidth Status Bar Indicators.

Enabling or Disabling the Connection Quality Indicator

The Connection Quality Indicator displays a measurement of your connection quality in the Status 
Bar. 

To enable or disable the Connection Quality Indicator:

1. Select Status Bar from the Options dialog box side navigation menu.
2. In the Connection Quality Indicator section, select or clear Show Connection Quality Indi-

cator according to your preference.
3. Click Apply to save your change.

Enabling or Disabling the Firewall Indicator

The Firewall Indicator displays your firewall status in the Status Bar. For information about fire-
walls, see “Glossary” on page 57.

To enable or disable the Firewall Indicator:

1. Select Status Bar from the Options dialog box side navigation menu.
2. In the Firewall Indicator section, select or clear Show Firewall Indicator according to your 

preference.
3. Click Apply to save your change.

Enabling or Disabling the Bandwidth Indicator

The Bandwidth Indicator displays your bandwidth consumption in the Status Bar. For information 
about bandwidth, see “Glossary” on page 57.

To enable or disable the Bandwidth Indicator:

1. Select Status Bar from the Options dialog box side navigation menu.
2. In the Bandwidth Indicator section, select or clear Show Bandwidth Indicator according to 

your preference.
3. Click Apply to save your change.
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Enabling or Disabling iTunes Importing

FrostWire can automatically import downloaded songs into your iTunes library. 

To enable or disable iTunes importing:

1. Select iTunes from the Options dialog box side navigation menu.
2. In the Importing section, select or clear Enable iTunes importing according to your prefer-

ence.
3. Click Apply to save your change.

Changing View Options

In the Options dialog box, you can change several settings related to FrostWire’s general display. 
You can choose to display FrostWire popups, FrostClick Promotions, and FrostWire recommen-
dations, and enable or disable text autocompletion.

Redisplaying FrostWire Popups

When you see popup messages in FrostWire, you can choose “Do not display this message again” 
or “Always use this answer”. If you wish to redisplay these messages and restore the default pop-
ups, you can do so.

To redisplay FrostWire popups:

1. Select View from the Options dialog box side navigation menu.
2. In the FrostWire Popups section, select Revert to Default.
3. Click Apply to save your change.

Enabling or Disabling FrostClick Promotions

FrostClick promotions promote artists and content creators on home page of FrostWire. You can 
choose to either enable or disable these promotions. FrostWire strongly recommends you leave 
them enabled.

To enable or disable FrostClick promotions:

1. Select View from the Options dialog box side navigation menu.
2. In the FrostClick Promotions section, select or clear Enable FrostClick Promotions accord-

ing to your preference.
3. Click Apply to save your change.
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Enabling or Disabling FrostWire Recommendations

FrostWire recommendations are sponsored offers and software recommendations to improve your 
experience with FrostWire. You can choose to enable or disable these recommendations. Frost-
Wire strongly recommends you leave them enabled.

To enable or disable FrostWire recommendations:

1. Select View from the Options dialog box side navigation menu.
2. In the FrostWire Recommendations section, select or clear Enable FrostWire Recommenda-

tions according to your preference.
3. Click Apply to save your change.

Enabling or Disabling Text Autocompletion

FrostWire can autocomplete text fields for you using text autocompletion.

To enable or disable text autocompletion:

1. Select View from the Options dialog box side navigation menu.
2. In the Text Autocompletion section, select or clear Enable Autocompletion of Text Fields 

according to your preference.
3. Click Apply to save your change.

Changing Filter Results 

In the Options dialog box, you can filter out search results based on a particular keyword. For 
information on keywords, see “Glossary” on page 57. You can also choose whether you want 
FrostWire to include adult content in search results. 

To add a keyword filter:

1. Select Filters from the Options dialog box side navigation menu.
2. In the Filter Results section, type the keyword you want to be excluded from search into the 

text box. 
3. Click Add. The word now appears in the filter results list.
4. Click Apply to save your change.
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To remove a keyword filter:

1. Select Filters from the Options dialog box side navigation menu.
2. In the Filter Results section, select the keyword filter you want to remove. 
3. Click Remove. The word no longer appears in the filter results list.
4. Click Apply to save your change.

To filter adult content from search results, select or clear Ignore Adult Content in the Filter 
Results section according to your preference. 

Changing Advanced Options

FrostWire has several advanced options that can be changed in the Options dialog box. 

Enabling or Disabling Automatic Installer Downloads

FrostWire can automatically download a new installer via BitTorrent when available. After down-
loading, the next time you start FrostWire you will be notified of the new installer. For informa-
tion about installers, see “Glossary” on page 57.

To enable or disable automatic installer downloads:

1. Select Advanced from the Options dialog box side navigation menu. 
2. Select Updates from the Advanced dropdown in the Options dialog box side navigation 

menu.
3. In the Automatic Installer Download section, select or clear Download new installers for me 

according to your preference.
4. Click Apply to save your change.
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Enabling or Disabling Experimental Features

Experimental ALPHA and BETA features can be enabled in FrostWire. These features are being 
developed and tested by FrostWire developers and may have problems. For information about 
ALPHA and BETA features, see “Glossary” on page 57.

Warning: Experimental features are unstable. FrostWire makes no guarantees of security, privacy 
or reliability when using ALPHA or BETA features. 

To enable or disable experimental features:

1. Select Advanced from the Options dialog box side navigation menu. 
2. Select Experimental from the Advanced dropdown in the Options dialog box side navigation 

menu.
3. In the Experimental Features section, select or clear Enable ALPHA features and/or Enable 

BETA features according to your preference.
4. Click Apply to save your change.

Configuring Firewalls and Routers

FrostWire can be configured to work behind a firewall or router. FrostWire can automatically con-
figure your firewall or router for optimal performance using UPnP. For information on UPnP, see 
“Glossary” on page 57. 

To use a random port: 

1. Select Advanced from the Options dialog box side navigation menu. 
2. Select Firewall from the Advanced dropdown in the Options dialog box side navigation 

menu.
3. In the Router Configuration section, select Use random port (recommended). This is 

selected by default.
4. Click Apply to save your change.

To enter a manual port range:

1. Select Advanced from the Options dialog box side navigation menu. 
2. Select Firewall from the Advanced dropdown in the Options dialog box side navigation 

menu.
3. In the Router Configuration section, select Manual port range.
4. Enter the PCP port start and end into the respective text boxes.
5. Click Apply to save your change.
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Configuring Proxy Options

FrostWire can be configured to operate using a proxy. For information about Proxies, see “Glos-
sary” on page 57.

To configure the Proxy Options:

1. Select Advanced from the Options dialog box side navigation menu. 
2. Select Proxy from the Advanced dropdown in the Options dialog box side navigation menu.
3. In the Proxy Options section, use the option buttons to select the Proxy type.
4. In the Proxy text box, enter a Proxy address.
5. In the Port text box, enter a port number. 
6. In the login details section, enter your username and password. 
7. Click Apply to save your change.

Changing Network Interface Options

You can instruct FrostWire to bind outgoing connections to a specific IP address from a specific 
network interface. For information about IP addresses, see “Glossary” on page 57.

To use a specific network interface:

1. Select Advanced from the Options dialog box side navigation menu. 
2. Select Network Interface from the Advanced dropdown in the Options dialog box side navi-

gation menu.
3. In the Network Interface section, select Use a specific network interface. 
4. Select the option button beside the network interface you wish to use. 
5. Click Apply to save your change.

Changing File Associations 

You can use FrostWire to always open certain file types and protocols.

To change the file association settings:

1. Select Advanced from the Options dialog box side navigation menu. 
2. Select File Associations from the Advanced dropdown in the Options dialog box side naviga-

tion menu.
3. In the Links and File Types section, under Use FrostWire for..., select “.torrent” files and/or 

“.magnet:” links according to your preference.
4. Under What should FrostWire do with the selected associations on startup?, select the option 

button beside your preferred option. 
5. Click Apply to save your change.
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Changing System Startup Options

You can choose whether to automatically open FrostWire when your computer starts. 

To change the system startup options:

1. Select Advanced from the Options dialog box side navigation menu. 
2. Select System Boot from the Advanced dropdown in the Options dialog box side navigation 

menu.
3. In the System Startup section, select or clear Run on System Startup according to your pref-

erence.
4. Click Apply to save your change.

Changing Shutdown Behaviour

You can change FrostWire’s shutdown behaviour using the Options dialog box. 

To change FrostWire’s shutdown behaviour:

1. Select System Tray from the Options dialog box side navigation menu.
2. In the Shutdown Behaviour section, select or clear Shutdown Immediately or Minimize to 

System Tray according to your preference.
3. If you want a Shutdown Behaviour dialog box to display before FrostWire closes, select Show 

dialog to ask before close. 
4. Click Apply to save your change.
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Changing Bug Report Options

You can choose how bug reports should be sent in FrostWire. To navigate to the Bug Reports page 
in the Options dialog box, select Bug Reports from the side navigation menu. See Table 7.1 for 
details on how to change FrostWire’s Bug Report Options. 

Restoring Default Settings

You can restore FrostWire’s default settings at any time using the Options dialog box. To restore 
FrostWire’s default settings, open the Options dialog box and click Restore Defaults.

If you want FrostWire to: Then select:

Immediately send a bug report when an error 
occurs

Always Send Immediately 

Ask for permission before sending a bug report Always Ask For Review 

Always ignore bugs and never send a bug report Always Discard All Errors 

Send bug reports automatically when frozen Send Errors Automatically if FrostWire 
is Frozen 

Image 7.2: Bug Report Options
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Glossary
Table 8.1: Glossarya

Term Definition

ALPHA The first phase of the software release and testing process. 
ALPHA software may contain serious errors, and any resulting 
instability could cause crashes or data loss.

Bandwidth The maximum rate of data transfer across a given path.

BETA The software development phase following ALPHA. BETA soft-
ware features are mostly complete but likely to contain a num-
ber of known or unknown bugs.

Distributed Hash Table 
(DHT)

A distributed system that provides a lookup service. DHTs form 
an infrastructure that can be used to build more complex ser-
vices like peer-to-peer file sharing. 

Firewall A network security system that establishes a barrier between a 
trusted network and an untrusted network.

Installer A computer program that installs files, such as applications, driv-
ers, or other software, onto a computer.

IP address Internet Protocol address (IP address) is a numerical label such 
as that is connected to a computer network. IP addresses are 
used to locate and identify users on a network. 

Keyword A word used for Internet search that is related in some way to 
the information being searched for. 
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Magnet link A standard for identifying files by their content.

Open source software Computer software that is released under a license in which the 
copyright holder grants users the rights to use, study, change, 
and distribute the software and its source code to anyone and 
for any purpose.

PCP Port Control Protocol (PCP) is a computer networking protocol. 

Peer-to-peer (P2P) Peer-to-peer (P2P) computing or networking is a distributed 
application architecture that divides tasks or workloads between 
peers in a network. 

Peers Peers are participants in a peer-to-peer (P2P) network. 

Pieces Fragments of a file that are distributed between peers across a 
peer-to-peer (P2P) network. 

Proxy A computer system or router that functions as a relay between a 
client and a server. 

Search engine A search engine is a software system that is designed to carry 
out web searches and return results based on keywords. 

Seeding The uploading of already downloaded content for others to 
download from on a peer-to-peer (P2P) network. 

Torrent A computer file that contains metadata about files and folders 
to be distributed on a network. 

Tracker A special type of server that assists in the communication 
between peers using the BitTorrent protocol.

UPnP Universal Plug and Play (UPnP) is a set of networking protocols 
that allows devices to discover each other's presence on a net-
work and establish functional network services.

URL A Uniform Resource Locator (URL), also known as a web address, 
is a reference to a web resource that specifies its location on a 
computer network and a mechanism for retrieving it.

VPN A virtual private network (VPN) enables users to send and 
receive data across shared or public networks as if their comput-
ing devices were directly connected to a private network.

a. All information retrieved from Wikipedia.

Table 8.1: Glossarya

Term Definition
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